SharePoint 2013 and Office WebApps: The Binding Dance Off!

3 02 2013

After installing SharePoint 2013 and configuring it with Workflows and app domains, the last piece of the puzzle is to install Office web apps. Pretty simple really if you follow these steps from SOWMYANCS :Install, Configure & Monitor Office Web Apps 2013 for SP 2013

However, no matter what i tried, i couldn’t get office web apps to work quite right. It wanted to launch in the window, but it would get stuck there for 5 minutes then tell me the office webapp service was busy or this dandy error:

Word Document: “Sorry, Word Web App can’t open this document because the service is busy.  Please try again later.”

Word Document : “Sorry, there was a problem and we can’t open this document. If this happens again, try opening the document in Microsoft Word.”

I scoured the internet and nothing. Then it dawns on me. I had demoted this server from being a Domain Controller. Somewhere in the instructions i had read that OWA server cannot be a domain controller. But it doesn’t say it should have NEVER been one either.

I went ahead and installed a fresh copy of Windows Server 2012 with all the updates.

I went back to my SharePoint WFE and ran:

Remove-SPWOPIBinding –All:$true

I re ran the steps from the above article

New-OfficeWebAppsFarm –InternalURL "http://servername" -ExternalURL "http://servername.contoso.com" –AllowHttp -EditingEnabled

and it STILL DID NOT WORK CORRECTLY. Hmmmm…
Turns out that SharePoint remembers all your SPWPIzones from before. So if you wan’t external access you need to run this command to make sure you know what zone you are in:

Get-SPWOPIZone

Then make sure you set your spopizone to external by running this command:

Set-SPWOPIZone –zone “external-https”

Now it works.
Moral of the story, don’t reuse domain controllers, even if you have demoted them. They will always be bitter you demoted them.

Nando

Advertisements

Actions

Information

3 responses

10 04 2014
dlgross

Thanks for the tip. We are getting this same error from SharePoint Online. any idea what could cause this in that environment?

10 04 2014
undrdg

SharePoint online is a totally different thing. I don’t think this trick works with it. What version of SharePoint designer are you running?

15 04 2015
surendar

even im getting same error, i dont know how to fix this issue.In my situation it is working fine for some of the document but it throwing same error for some document.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s




%d bloggers like this: